hoja calculo

Download Hoja calculo

Post on 07-Jun-2015

12.393 views

Category:

Documents

6 download

Embed Size (px)

TRANSCRIPT

  • 1. Hoja de ClculoHoja de Clculo GUZMN-RINCNUniversidad Rey Juan Carlos 12000,2002Hoja de ClculoIntroduccin Una hoja de clculo es una especie de tabla cuyas casillas o celdas pueden contener:! Texto !Valores numricos !Frmulas o funciones matemticas !Grficos GUZMN-RINCNUniversidad Rey Juan Carlos 22000,2002

2. Pantalla principal de Excel GUZMN-RINCN Universidad Rey Juan Carlos 32000,2002 Hoja de Clculo Hojas y libros Un libro consta de una o varias hojas y se guarda en un archivo. Es posible aadir hojas al libro, eliminarlas, duplicarlas y cambiarlas deposicin. !Aadir una hoja: Insertar / Hoja de clculo.!Eliminar una hoja: Edicin / Eliminar hoja.!Duplicar hoja o cambiarla de posicin: Edicin / Mover o copiar hoja. GUZMN-RINCN Universidad Rey Juan Carlos 42000,2002 3. Hoja de ClculoEditar celdas !Celda activa: sobre la que se encuentra el cursor.!Celdas seleccionadas: aparecen en vdeo inverso.!Modificar el contenido de una celda: posicionarse sobre ella y pulsar F2.!Cortar, copiar y pegar celdas: uso habitual.!Edicin / Rellenar: muy til para propagar la frmula de una celda a otrasde su misma fila o columna.!Insertar o eliminar filas o columnas. GUZMN-RINCNUniversidad Rey Juan Carlos 52000,2002 Hoja de Clculo Referenciar celdas y conjuntos de celdasLas celdas se referencian por sus coordenadas de columna y de fila: A1, B5, etc.Los rangos rectangulares de celdas se referencian mediante las posiciones de sus extremos. Ej: el rango A5:B7 referencia las celdas A5,A6,A7,B5,B6 y B7.Se pueden referenciar varias celdas o rangos dispersos separndolos por el carcter ; Ej: el rango A2:B3;B6:C8 referencia las celdas A2,A3,B2,B3,B6,B7,B8,C6, C7 y C8. GUZMN-RINCNUniversidad Rey Juan Carlos 62000,2002 4. Hoja de ClculoFormatear celdas Es posible definir el formato de los datos contenidos en las celdas. Para ello habr que recurrir a la opcin Formato de la ventana principal o bien a los iconos de la barra de herramientas de formato. ! Categora del dato: general, nmero, fecha,moneda, texto, cientfico, etc.!Alineacin del contenido!Tipo de fuente empleada.!Tipos de bordes y de tramas de la celda.!Opciones de proteccin de celdas. GUZMN-RINCN Universidad Rey Juan Carlos72000,2002 Hoja de Clculo Proteger celdas y hojas Es posible proteger el contenido de las hojas de clculo o de celdas individuales para prevenir su posible modificacin por error o por terceros.!Desproteger la hoja: elegir Herramientas / Proteger / Desproteger hoja. !Proteger/desproteger celdas: seleccionar las celdas, elegir Formato / Celdas / Proteger y activar/desactivar la opcin Bloquear (la hoja debe estar desprotegida). ! Proteger la hoja: elegir Herramientas / Proteger / Proteger hoja. Para que la proteccin de celdas sea efectiva, es necesario que la hoja est protegida.GUZMN-RINCN Universidad Rey Juan Carlos82000,2002 5. Hoja de Clculo Crear Frmulas Para realizar operaciones con Excel, debemos emplear lo que el programa denomina frmulas. Estas frmulas se pueden dividir en dos tipos: ! Simples: introducen operadores comunes como:+,-,*,/etc. ! Complejas o funciones: utilizan nombres de frmulas predefinidas por Excel GUZMN-RINCN Universidad Rey Juan Carlos 92000,2002Hoja de Clculo Crear Frmulas Simples Tipos de operadores: Aritmticos: * Producto. + Suma. - Diferencia. % Porcentaje. ^ Potencia. / Cociente. De Comparacin: > Mayor. < Menor.Devuelven: VERDADERO/FALSO Distinto. (=) (menor o igual) y (mayor o igual) GUZMN-RINCN Universidad Rey Juan Carlos 102000,2002 6. Hoja de Clculo Tipos de operadores: de Referencia:: Englobar un rango de celdas.; Seleccionar celdas individualmente. De Texto:& Concatenar. GUZMN-RINCNUniversidad Rey Juan Carlos 112000,2002Hoja de ClculoEjemplo.Deseamos calcular la nota final de estos alumnos. Se tiene unacalificacin de un examen terico y otra de la parte de prcticas. Laprimera supone un 60 % de la nota final y la segunda un 40%. Partimos de la siguiente informacin: GUZMN-RINCNUniversidad Rey Juan Carlos 122000,2002 7. Hoja de Clculo Ejemplo.Introducimos la expresin de lafrmula que proporciona el resultado deseado en la celdacorrespondiente. =((60%)*D6)+((40%)*E6) Copiamos la frmulaque acabamos de escribir al resto de lasceldas donde querealizar el mismoclculo. Utilizamos paraello el Autollenado que proporciona Excel.GUZMN-RINCNUniversidad Rey Juan Carlos132000,2002Hoja de Clculo Ejemplo.La expresin que calcula la nota final se copia a las celdas adyacentes conlo que nos ahorramos la traduccin en celdas de la expresin, al escribirlaen otra parte. GUZMN-RINCNUniversidad Rey Juan Carlos142000,2002 8. Hoja de Clculo Crear Frmulas ComplejasExcel posee una serie de frmulas predefinidas llamadasfunciones que podemos introducir directamente, indicandotan slo el rango de celdas con el que se deber realizar laoperacin. El rango de celdas se puede definir de dosformas: introduciendo una a una las celdas (operador ;) ofijando el intervalo (operador :).Funciones BsicasLa Suma (no representada en este apartado): realiza una sumade los datos contenidos en un rango. Su formula genrica es: =SUMA(rango).GUZMN-RINCNUniversidad Rey Juan Carlos152000,2002Hoja de ClculoFunciones Bsicas El promedio o Media Aritmtica: suma los datos de un rango y divideel resultado entre el nmero total de datos. Su frmula genrica es: =PROMEDIO(rango).El Mximo: devuelve el valor mximo de un grupo de datos. Su frmulagenrica es:=MAX(rango).El Mnimo: devuelve el valor mnimo de un grupo de datos. Su frmulagenrica es: =MIN(rango). GUZMN-RINCNUniversidad Rey Juan Carlos162000,2002 9. Hoja de ClculoFunciones Bsicas Clculo del valor absoluto de un dato numrico:=ABS(dato)Clculo de la parte entera de un dato numrico:=ENTERO(dato)Elevar un valor numrico a una potencia:=POTENCIA(base;exponente)Obtener el resto de una divisin=RESIDUO(dividendo;divisor) GUZMN-RINCN Universidad Rey Juan Carlos172000,2002 Hoja de ClculoFunciones Bsicas La Mediana: devuelve el valor medio de un grupo de datos, es decir, el que est a la misma distancia en datos del primero y del ltimo. Su frmula genrica es: =MEDIANA(rango). La frmula Contar: Cuenta el nmero de celdas que contienen un dato no vacio en un rango indicado, es decir, no cuenta las celdas vacias. Su frmula genrica es: =CONTAR(rango). GUZMN-RINCN Universidad Rey Juan Carlos182000,2002 10. Hoja de ClculoFunciones Bsicas La funcin SI: Permite la estructura compleja de las operacionesintroduciendo una condicin cuya comprobacin determinar unaactuacin u otra. Su sintaxis es: = SI(X;Y;Z). X Valor lgico (p.e. B4 > 0) Si X se cumple se realiza Y. Si X no se cumple se realiza Z.La funcin SI se puede anidar para crear asignaciones medianteestructuras condicionales complejas. GUZMN-RINCNUniversidad Rey Juan Carlos 192000,2002Hoja de Clculo Funciones Bsicas Las funciones lgicas evalan condiciones y devuelven el valorVERDADERO o el valor FALSO. Pueden emplearse para definircondiciones complejas en estructuras condicionales con la funcin SI.Conjuncin:=Y(condicin1;condicin2;...;condicinN)Disyuncin:=O(condicin1;condicin2;...;condicinN)Negacin:=NO(condicin)Hay ms funciones que devuelven valores lgicos.Ejemplo: =ESNUMERO(dato) devuelve VERDADERO si elargumento es un valor numrico y FALSO si no lo es.GUZMN-RINCNUniversidad Rey Juan Carlos 202000,2002 11. Hoja de ClculoEjemplo. Continuando con el ejemplo anterior, calculamos de nuevo las notasfinales de los alumnos y ahora, adems, determinamos lascalificaciones que el aprobado este en el 5, como nota lmite.Calculamos, tambin, la nota media de la clase.Ahora partimos de la siguiente estructura de datos GUZMN-RINCNUniversidad Rey Juan Carlos212000,2002Hoja de ClculoEjemplo.Introducimos la expresin de la frmula que proporciona el valor dela nota final en la celda correspondiente. =SUMA(PRODUCTO((60%);D6);PRODUCTO((40%);E6))Utilizaremos el Autollenado para extender la expresin a toda la columna de Nota Final GUZMN-RINCNUniversidad Rey Juan Carlos222000,2002 12. Hoja de Clculo Ejemplo.Introducimos la expresin de la frmula que nos va a proporcionarel criterio para determinar cuando un alumno esta aprobado. Paraello marcamos en la celda C12 el valor de la nota de corte. =SI(G6>$C$12;"APTO/A";"NO APTO/A")Utilizaremos el Autollenado para extender la expresin a toda la columna de Calificacin. GUZMN-RINCNUniversidad Rey Juan Carlos 232000,2002Hoja de Clculo Ejemplo.Introducimos la expresin de la frmula que nos va a proporcionarla nota promedio de la clase. =PROMEDIO(G6:G9) GUZMN-RINCNUniversidad Rey Juan Carlos 242000,2002 13. Hoja de Clculo Ejemplo.La referencia que hemos utilizado para pasar como argumento dela funcin =PROMEDIO el rango de celdas (G6:G9) se puederealizar de una forma alternativa; asignando al rango de celdasun nombre de rango. Seleccionamos las celdas que definen elrango sobre el que queremos realizaralgn tipo de clculo.Elegimos el nombre con l que referirnos alrango de celdas y lo escribimos. GUZMN-RINCN Universidad Rey Juan Carlos252000,2002Hoja de Clculo Ejemplo.Ahora cuando escribimos la expresin que nos calcula la notamedia de la clase escribiremos:=PROMEDIO(nota_final)GUZMN-RINCN Universidad Rey Juan Carlos262000,2002 14. Hoja de ClculoEjemplo.Analizamos a continuacin las expresiones que hemos utilizado para realizar los sencillos que se nos proponan en este ejemplo.=SUMA(PRODUCTO((60%);D6);PRODUCTO((40%);E6)) =SI(G6>$C$12;"APTO/A";"NO APTO/A")=PROMEDIO(nota_final) GUZMN-RINCNUniversidad Rey Juan Carlos272000,2002Hoja de ClculoConclusiones: Se pueden combinar operadores simples conestructuras complejas predefinidas por Excel. Se pueden anidar las funciones utilizando losresultados de unas como argumentos de otras. Aparicin de un nuevo operador: $. Permitirintroducir un nuevo concepto: distincin entre referenciasde celdas relativas y referencias absolutas. GUZMN-RINCNUniversidad Rey Juan Carlos282000,2002 15. Hoja de Clculo Frmulas Relativas y Absolutas. Cuando introducimos los argumentos de las fun