01 excel avanzado 2013

Download 01 Excel Avanzado 2013

Post on 14-Oct-2015

32 views

Category:

Documents

0 download

Embed Size (px)

TRANSCRIPT

  • 5/24/2018 01 Excel Avanzado 2013

    1/16

    3

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    1. USO DEL CUADRO DE CONTROLES PARA APLICACIONESPara poder trabajar con controles para aplicaciones habilitamos primeramente la pestaa o fichallamada DESARROLLADOR:

    ARCHIVOOpcionesPersonalizar cinta de opciones

    Habilitamos Desarrolladorde la siguiente forma:

    Luego pulsamos el botn de comando Aceptar, de tal manera que quede as:

    Crear una nueva hoja de clculo llamado: Sesin 01, ingresar datos desde H1:H20tal como se muestra

    a continuacin:

  • 5/24/2018 01 Excel Avanzado 2013

    2/16

    4

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Seleccionamos toda la hoja Botn y vamos a DESARROLLADORCdigo - Grabar Macro.

    - Nombre a la macro: Formato- Tecla de mtodo abreviado: C-

    Guardar macro en: Este Libro- Descripcin: Macro grabada el 16/11/2013 por Lenin Huayta FloresPulse el botn de comando Aceptar.

    Cambiamos el formato de fuente en la pestaa INICIO

    - Fuente: Garamond- Tamao: 16- Color: Verde

  • 5/24/2018 01 Excel Avanzado 2013

    3/16

    5

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    - Negrita, Cursiva y Subrayado.

    Detener el grabado de la macro en la pestaa DESARROLLADORCdigoDetener grabacin.

    Veamos el cdigo generado en DESARROLLADORCdigoVisual BasicMdulo 1.

    Otra manera de acceder es pulsando la combinacin de teclas ALT + F11.

    Seleccionamos la hoja Botne ir a INICIOModificarBorrarBorrar formatos

  • 5/24/2018 01 Excel Avanzado 2013

    4/16

    6

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Guardar el archivo con el Nombre Sesin 01, activando el Tipo: Libro de Excel habilitado para macros

    Guardar.

    Luego escriba su nombre y apellidos en cualquier celda de la hoja Botn, e ir a DESARROLLADOR

    Macros - Ver macros

  • 5/24/2018 01 Excel Avanzado 2013

    5/16

    7

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Seleccionamos la macro Formatoy hacemos clic en Ejecutar.

    Seleccionar las celdas e ir a INICIOModificarBorrarBorrar formatos.

    Inserte un botn: DESARROLLADORInsertarControles de formularioBotn

    Dibuje el botn y seleccione la macro Formatoy haga clic en el botn de comando Aceptar:

  • 5/24/2018 01 Excel Avanzado 2013

    6/16

    8

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Cambiar el texto del botn haciendo clic derecho sobre el botn y seleccione Modificar texto:

    Cambiamos el nombre del botn a Formato, hacer clic fuera del botn.

    Escriba un texto en la hoja y presione el botn de comando Formato.

    Activar la hoja Cuadro combinadoe ir a: DESARROLLADORInsertarCuadro combinado

  • 5/24/2018 01 Excel Avanzado 2013

    7/16

    9

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Dibujar el cuadro combinado en la hoja, haga clic derecho encima del cuadro combinado y seleccionarFormato

    de control.Rango de entrada: (Seleccione el rango de entrada en la hoja Datosdesde H1:H20)

    Vincular con la celda: A1

    De manera que, quede as:

    Activar la hoja Casilla e ir a: DESARROLLADORInsertarCasilla

  • 5/24/2018 01 Excel Avanzado 2013

    8/16

    10

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Dibujar 3 casillas en la hoja, cambie los nombres de las casillas:

    Haga clic derecho encima las casillas e ir a Formato de control.

    Vincular con la celda: A1 (Bsico),A2 (Intermedio)yA3 (Avanzado) respectivamente.

    Veamos el comportamiento de las casillas:

  • 5/24/2018 01 Excel Avanzado 2013

    9/16

    11

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Activar la hoja Control de Nmeroe ir a: DESARROLLADORInsertarControl de nmero

    Dibujar el control de nmero en la hoja, haga clic derecho encima del control y seleccionarFormato de control.

    Valor actual: 1

    Valor mnimo: 1Valor mximo: 100

    Incremento: 1

    Vincular con la celda: A1

    Veamos el comportamiento del control de nmero:

  • 5/24/2018 01 Excel Avanzado 2013

    10/16

    12

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Activar la hoja Cuadro de lista e ir a: DESARROLLADORInsertarCuadro de lista

    Dibujar el cuadro de lista en la hoja, haga clic derecho encima del control y seleccionarFormato de control.Rango de entrada: (Seleccione el rango de entrada en la hoja Datosdesde H1:H20)

    Vincular con la celda: A1

    Presionamos el botn de comando Aceptar.

    De manera que, quede as:

  • 5/24/2018 01 Excel Avanzado 2013

    11/16

    13

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Activar la hoja Botn de opcin e ir a: DESARROLLADORInsertarBotn de opcin

    Dibujar 2 botones de opcin en la hoja, cambie los nombres de los botones:

    Haga clic derecho encima del botn de opcin Masculinoe ir a Formato de control.

    Vincular con la celda: A1 (Masculino) yA1 (Femenino).

    Veamos el comportamiento de los botones de opcin:

  • 5/24/2018 01 Excel Avanzado 2013

    12/16

    14

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Activar la hoja Cuadro de grupo y Etiqueta e ir a: DESARROLLADORInsertarCuadro de grupo e

    insertar Etiqueta

    Dibujar un Cuadro de grupo y una Etiqueta2 botones de opcin en la hoja, cambie los nombres de los botones:

    Estos controles son utilizados para el diseo de nuestros formularios.

  • 5/24/2018 01 Excel Avanzado 2013

    13/16

    15

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Activar la hoja Barra de desplazamiento e ir a: DESARROLLADORInsertarBarra de desplazamiento

    Dibujar la barra de desplazamiento en la hoja, haga clic derecho encima del control y seleccionarFormato decontrol.

    Valor actual: 1

    Valor mnimo: 0

    Valor mximo: 100

    Incremento: 5

    Cambio de pgina: 10

    Vincular con la celda: A1

    Presionamos el botn de comando Aceptar.

    Veamos el comportamiento de la barra de desplazamiento:

  • 5/24/2018 01 Excel Avanzado 2013

    14/16

    16

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    1.1.PRCTICA 01Abrir el archivo Prctica 01.xlsx, en activamos la hoja Registroy realizamos el siguiente formulario

    Valores de las celdas:

    D6:=HOY()

    B14:Clic derecho en el Cuadro combinadoFormato de control

    B16:Clic derecho en el Cuadro combinadoFormato de control

    B18:=BUSCARV(C16,Datos!A15:C19,3,FALSO)

  • 5/24/2018 01 Excel Avanzado 2013

    15/16

    17

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    Botones de opcin: Contratado y Nombrado

    Guardarcomo archivo macro Prctica 01.xlsm (ARCHIVOGuardar comoEquipoExaminar)

    Presione el botn de comando Aceptar.

    Ir a la pestaa o ficha DESARROLLADORVisual Basico puede tambin realizando la combinacin de

    teclas ALT + F11, creamos un Mdulo1(clic derecho en VBAProject (Prctica 01.xlsm)Insertar

    Mdulo).

  • 5/24/2018 01 Excel Avanzado 2013

    16/16

    18

    UNIVERSID D N CION L DEL LTIPL NOCentro e Cmputo e In ormtica

    Ing. Lenin Huayta Flores

    En Mdulo 1 crear el procedimiento Registro() y realizar el cdigo siguiente:

    Sub Registro()

    Dim HojaPlanilla As Worksheet

    Dim HojaRegistro As Worksheet

    Set HojaPlanilla = Worksheets(3)

    Set HojaRegistro = Worksheets(2)

    Dim i As Integer

    i = HojaRegistro.Range("c23")

    HojaPlanilla.Cells(i, 1).Value = HojaRegistro.Cells(8, 2).Value

    HojaPlanilla.Cells(i, 2).Value = HojaRegistro.Cells(10, 2).Value

    HojaPlanilla.Cells(i, 3).Value = HojaRegistro.Cells(12, 2).Value

    HojaPlanilla.Cells(i, 4).Value = HojaRegistro.Cells(14, 3).Value

    HojaPlanilla.Cells(i, 6).Value = HojaRegistro.Cells(16, 3).Value

    HojaPlanilla.Cells(i, 8).Value = HojaRegistro.Cells(18, 2).Value

    HojaPlanilla.Cells(i, 9).Value = HojaRegistro.Cells(21, 3).Value

    HojaPlanilla.Cells(i, 11).Value = HojaRegistro.Cells(6, 4).Value

    HojaRegistro.Range("c23").Value = HojaRegistro.Range("c23").Value + 1

    End Sub

    Al Botnde comando Registrarse le asigna la macro Registro

    Activar la hoja Planillay realice lo siguiente:

    Valores de celdas:

    E6: =SI(D6>0,BUSCARV(Planilla!D6,Datos!$A$2:$B$6,2,FALSO),"")

    G6: =SI(F6>0,BUSCARV(F6,Datos!$A$15:$C$19,2,FALSO),"")J6: =SI(I6=1,"Contratado",SI(I6=2,"Nombrado",""))

    Activar la hoja Constancia, realice lo siguiente:

    Valores de celdas:

    B11: =BUSCARV(B9,Planilla!A6:K19,2)

    B13: =BUSCARV(B9,Planilla!A6:K19,3)

    B15: =BUSCARV(B9,Planilla!A6:K19,5)

    B17: =BUSCARV(B9,Planilla!A6:K19,7)

    B19: =BUSCARV(B9,Planilla!A6:K19,8)

    H9: =BUSCARV(B9,Planilla!A6:K19,11)

    H13: =BUSCARV(B9,Planilla!A6:K19,10)

    H26:=AHORA()

    Guarde los cambios e ingrese datos.